Testing Your Own Application — Getting Started 

Follow the procedure outlined below when testing your own application. 

1. Plan your test.
Decide how to organize your test. Consider what users will want to accomplish when deciding which operations to record. Confirm that your application and QuickTest are set to match the needs of your test. 

Decide which object repository mode to use for your test. The object repository mode you choose determines the way that QuickTest stores information about your application when you record tests. You can have a separate action repository for each action and store the objects for each action in its corresponding action repository, or you can store all the objects in your test in a common (shared) object repository file. You can also use the same shared object repository file for multiple tests. 

If you are new to testing, you may want to use the object repository per-action mode, as you can use this mode without making any other changes to your test. 

If you are familiar with testing, it is probably most efficient to work in the shared object repository mode. In this mode, you can use one object repository file for multiple tests. This means that object information that applies to many tests is kept in one central location. When the objects in your application change, you can update them in one location for all of your tests. 

2. Record your test. 
While recording, follow the steps you expect users to perform as they navigate within your application or Web site. 

3. Enhance your recorded test.
Add checkpoints to search for specific values of a page, object, text string, or table.Replace fixed values in your test with parameters to check how your  application performs the same operations with multiple sets of data.  Create output values to retrieve data during a test run. Where applicable, use regular expressions to increase the flexibility and adaptability of your tests. You can further enhance your test with programming and conditional statements, which add logic to your test. 

4. Debug your test.
Debug your test to check that it operates smoothly and without interruption. 

5. Run your test.
Run your test on your application or Web site to check that it functions as expected. 

6. Analyze the test results.
Examine the results of your test to pinpoint defects in your application. (Refer to the appropriate sections of this tutorial to understand what to look for in the test results.) 

7. Report defects.
If you have TestDirector installed, you can submit any defects discovered to a TestDirector database. TestDirector is Mercury Interactive’s tool for software test management. 

Recording a Test 

1. Start QuickTest  and open a new test.
If QuickTest is not currently open, choose Start > Programs > QuickTest Professional > QuickTest Professional. 

In the Add-in Manager, confirm that the Web Add-in is selected, and clear all other add-ins. Click OK to close the Add-in Manager and open QuickTest. 

Note: While QuickTest loads your selected add-ins, the QuickTest splash screen is displayed. This may take a few seconds. 

If the Welcome window opens, click Blank Test. 

Otherwise, choose File > New, or click the New button 
A blank test opens. 

Note: If the Add-in Manager does not open when starting QuickTest, choose Tools > Options. In the General tab, select Display Add-in Manager on startup. When you exit and restart QuickTest, the Add-in Manager opens. 

2. Start recording on the Any Web Site
[image: image25.wmf] 

Choose Test > Record or click the Record button. The Record and Run Settings dialog box opens. 

In the Web tab, select Open the following browser when a record or run session begins. 

Choose a browser from the Type list and confirm that the URL in the Address box is http://localhost/eposter.  

Confirm that Close the browser when the test is closed is selected. 

QuickTest begins recording, and your browser opens to the ePoster Web site. 
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In the Windows Applications tab, confirm that Record and run on these applications is selected, and that there are no applications listed.



This setting prevents you from inadvertently recording operations performed on various Windows applications (such as e-mail) during a recording session. 

Click OK. 

3. Stop recording.
In QuickTest, click Stop on the test toolbar to stop the recording process. QuickTest recorded your Web browser operations from the time you clicked the Record button until you clicked the Stop button. 

4. Save your test.
Select File > Save or click the Save button. The Save dialog box opens to the Tests folder. 

Understanding Checkpoint Types 

QuickTest Professional offers the following types of checkpoints:

	Checkpoint Type 
	Description 
	Example of Use 

	Standard Checkpoint 
	Checks values of an object’s properties 
	Check that a radio button is selected. 

	Image Checkpoint 
	Checks the property values of an image 
	Check that the image source file is correct. 

	Table Checkpoint 
	Checks information in a table 
	Check that the value in a table cell is correct. 

	Page checkpoint 
	Checks the characteristics of a Web page 
	Check how long a Web page takes to load or if a Web page contains broken links. 

	Text / 
Text Area Checkpoint 
	Checks that a text string is displayed in appropriate place in a Web page or application window 
	Check whether the expected text string is displayed in the expected location on a Web page or dialog box. 

	Bitmap Checkpoint 
	Checks an area of a Web page or application after capturing it as a bitmap 
	Check that a Web page (or any portion of it) is displayed as expected. 

	Database Checkpoint 
	Checks the contents of databases accessed by an application or Web site 
	Check that the value in a database query is correct. 

	Accessibility Checkpoint 
	Identifies areas of a Web site to check for Section 508 compliancy 
	Check if the images on a Web page include ALT properties, required by the W3C Web Content Accessibility Guidelines. 

	XML Checkpoint 
	Checks the data content of XML documents 
	Note: XML file checkpoints are used to check a specified XML file; XML application checkpoints are used to check an XML document within a Web page. 


You can add most checkpoints to your test either while recording or afterwards. 

Note: When QuickTest creates a checkpoint, it assigns a name based on information inside the checkpoint—the checked value, for example. The checkpoint name remains unchanged, even if you subsequently modify the information on which it was based. Keep this in mind when looking for checkpoints displayed in the Tree View. However, note that QuickTest may shorten the name displayed in the Tree View. 

Checking Objects 

In this section, you will add a standard checkpoint in the Book a Flight page. This checkpoint will verify the value in the box containing the first name of the passenger. 

1. Record the actions, which is to be tested.
2. Confirm that the Active Screen option is enabled.
If you do not see the Active Screen on the right side of the QuickTest window, click the Active Screen toolbar button [image: image1]or choose View > Active Screen. 

3. Locate the page where you want to add a standard checkpoint.
You want to add a checkpoint that checks the property values of the Quantity edit box after the Ordered Quantity has been entered in the box. 

In the test tree, expand (+) Action1 > "ePoster Store”> "Products". 

The Products page is displayed in the Active Screen and the object corresponding to the selected step is highlighted. You can see that the Ordered Qty is displayed in the Quantity box. 

4. Create a standard checkpoint.
In the Active Screen, right-click the First Name box and choose Insert Standard Checkpoint. The Object Selection – Checkpoint Properties dialog box opens.
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Confirm that WebEdit: passFirst0 is highlighted, and click OK. 
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The Checkpoint Properties dialog box opens.



The dialog box displays the object’s properties: 

· The Logical name is the name of the object as defined in the HTML code of the Web page. 

· The Class is the type of object. WebEdit indicates that the object is an edit box.

· The ABC icon in the type column indicates that the value of the property is a constant. 

For each object class, QuickTest recommends default property checks. The table below describes the default checks.

	Property 
	Value 
	Explanation 

	html tag 
	INPUT 
	INPUT is the html tag as defined in the HTML source code. 

	innertext 
	  
	In this case, the value of innertext is empty. The checkpoint checks that the value is empty. 

	name 
	passFirst0 
	passFirst0 is the name of the edit box. 

	type 
	text 
	text is the type of object as defined in the HTML source code. 

	value 
	<FirstName> 

(The name you entered while recording) 
	The value entered in the edit box. 


Accept the default settings and click OK. QuickTest adds a standard checkpoint step to your test above the selected step. 

[image: image3]
5. Save the test.
Choose File > Save or click the Save button [image: image4]. 

You insert most checkpoints in the manner described above. Several special types of checkpoints are explained in the following sections. 

Checking Pages 

In this section, you will add a page checkpoint to your test. The page checkpoint checks that the number of links and images in the page when you run your test is the same as when you recorded your test. 

1. Locate the page where you want to add a page checkpoint.
In the test tree, expand (+) Action1 > "Welcome: Mercury". 

Highlight the "Book a Flight" page [image: image5]in the test tree. The page is displayed in the Active Screen. 

2. Create a page checkpoint.
Right-click anywhere in the Active Screen, and choose Insert Standard Checkpoint. The Object Selection – Checkpoint Properties dialog box opens. Note that this dialog box may include different elements, depending on where you click in the Active Screen. 

Highlight Page: Book a Flight (the top level) and click OK.
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The Page Checkpoint Properties dialog box opens. 



When you run the test, QuickTest checks the number of links and images in the page and the load time, as described in the pane at the top of the dialog box. 

QuickTest also checks the actual target URL of each link and the actual source of each image. 

Accept the default settings and click OK. 

QuickTest adds the page checkpoint to your test. It is displayed in the test tree as a new step under the Book a Flight page. 


3. Save the test.
Choose File > Save or click the Save button 
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Checking Text 

In this section, you will add a text checkpoint to your test to check if “New York” is displayed in the "Flight Confirmation" page. 

1. Locate the page where you want to add a text checkpoint.
In the test tree, expand (+) Action1 > "Welcome: Mercury". 

Highlight the "Flight Confirmation" page in the test tree. The page is displayed in the Active Screen. 

2. Create a text checkpoint.
In the Active Screen, under “Departing,” highlight New York. 
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Right-click the highlighted text and choose Insert Text Checkpoint. The Text Checkpoint Properties dialog box opens.
When Checked Text appears in the list box, the Constant field displays the text string you highlighted. This is the text QuickTest looks for when running the test. 

Click OK to accept the default settings in this dialog box. 

QuickTest adds the text checkpoint to your test before the selected step. It is displayed in the test tree as a new step under the "Flight Confirmation" page. 
Save the test.
Choose File > Save or click the Save button. 

Checking Tables 

In this section, you will add a table checkpoint to check the cost of the outbound flight, as displayed in the Book a Flight page. 

1. Locate the page where you want to add a table checkpoint.
In the test tree, expand (+) "Welcome: Mercury". 

Highlight the "Book a Flight" page in the test tree. The page is displayed in the Active Screen. 

2. Create a table checkpoint.
In the Active Screen, right-click the price displayed for the first flight (New York to San Francisco)—270—and choose Insert Standard Checkpoint. 

The Object Selection – Checkpoint Properties dialog box opens. 

Select WebTable: New York to San Fransisco.
Note that the table you selected is highlighted in the Active Screen. Click OK. 

The Table Checkpoint Properties dialog box opens, showing the rows and columns of the table.
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Note that by default, check marks appear in all cells. You can double-click a cell to toggle the cell selection, or double-click a row or column header to toggle the selection for all the cells in the selected row or column. 

Double-click each column header to clear the check marks. Double-click column 3, row 3 to check the value of this cell. (QuickTest checks only cells containing check marks.) 

[image: image6]
Tip: You can change the column widths and row heights by dragging the boundaries of the column and row headers. 

Click OK to close the dialog box. 

QuickTest adds the table checkpoint to your test. It is displayed in the test tree as a new step under the "Book a Flight" page. 

[image: image7]
3. Save the test.
Choose File > Save or click the Save button [image: image8]. 

Regular Expression Syntax 

Regular expressions enable QuickTest to identify objects and text strings with varying values. You can use regular expressions when defining the properties of an object, the methods of an argument, when parameterizing a step, and when creating checkpoints with varying values. 

A regular expression is a string that specifies a complex search phrase. By using special characters such as a period (.), asterisk (*), caret (^), and brackets ([ ]), you define the conditions of the search. For more information on regular expression syntax, refer to the QuickTest Professional User’s Guide. 
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Working with Regular Expressions 

In this tutorial, you will create a text checkpoint on a date text string that changes according to the selected flight date. You can define the date as a regular expression so that the checkpoint checks that the captured text string matches the expected format, rather than checking the exact text. 

To do this, you will create a text checkpoint with a regular expression that will match any single character within a defined range. 

1. Start QuickTest [image: image11]and open the Recording test.
If QuickTest is not already open, choose Start > Programs > QuickTest Professional > QuickTest Professional. 

· If the Welcome window opens, click Open Existing. 

· If QuickTest opens without displaying the Welcome window, choose 
File > Open or click the Open button [image: image12]. 

In the Open QuickTest Test dialog box, locate and select the Recording test, then click Open. 

2. Save the test as RegExpression.
Select File > Save As. Save the test as RegExpression. 

3. Confirm that the Active Screen option is enabled.
If you do not see the Active Screen on the right side of the QuickTest window, click the Active Screen toolbar button [image: image13]or choose View > Active Screen. 

4. Select the text for which you will create the checkpoint.
In the test tree, expand (+) "Welcome: Mercury" and click the "Select a Flight:" page. The page is displayed in the Active Screen. 

In the Active Screen, scroll up and highlight the date for the outbound flight, New York to San Francisco (12/29/2003). Right-click the highlighted string and select Insert Text Checkpoint. The Text Checkpoint Properties dialog box opens. 

5. Enter the regular expression for the text you want to check.
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In the Checked Text area, click the Edit Constant Value Options button [image: image14]. The Constant Value Options dialog box opens.



In the Value box, replace the current date with [0-1][0-9]/[0-3][0-9]/200[0-9]. This instructs QuickTest to check that each character in the selected text matches the number-range format defined by the regular expression. The expression checks for the following format: MM/DD/200Y. 

Select the Regular expression check box. A message box prompts you to insert the backslash character before each special character. Click No. 

Note: Clicking Yes would cause QuickTest to treat the special characters ( [ ), ( - ) and ( ] ) as literal characters and not as a regular expression. 
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Click OK to accept the other default settings and close the Constant Value Options dialog box. The Text Checkpoint Properties dialog box opens.



Click OK to close the Text Checkpoint Properties dialog box. 

QuickTest adds the text checkpoint [image: image15]to your test. It is displayed as a new step in the test tree under the "Select a Flight:" page. 

6. Save the test.
Select File > Save or click the Save button [image: image16]. 
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Creating an Output Value 

In Parameterizing Tests, the second and third iterations of your test failed because the ticket price changed when the departure city changed. The checkpoint that checked the fare of the outbound flight in the Book a Flight page did not update its expected value as the fare changed. 

In this exercise, you will create an output value that retrieves the outbound fare from the Select a Flight page in each test iteration. You will then modify the table checkpoint you created, so that it checks that the price displayed in the Book a Flight page matches the price captured in the Select a Flight page. 

1. Start QuickTest [image: image19]and open the Parameter test.
If QuickTest is not already open, choose Start > Programs > QuickTest Professional > QuickTest Professional. 

· If the Welcome window opens, click Open Existing. 

· If QuickTest opens without displaying the Welcome window, choose 
File > Open or click the Open button [image: image20]. 

In the Open QuickTest Test dialog box, locate and select the Parameter test, then click Open. 

2. Save the test as Output.
Select File > Save As. Save the test as Output. 

3. Confirm that the Active Screen option is enabled.
If you do not see the Active Screen on the right side of the QuickTest window, click the Active Screen toolbar button [image: image21]or choose View > 
Active Screen. 

4. Select the text you want to use as an output value.
In the test tree, expand (+) "Welcome: Mercury" and click the "Select a Flight" page. The page is displayed in the Active Screen. 
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In the Active Screen, highlight the fare, without the $ sign, for the outbound flight (New York to San Francisco)—270. Right-click the highlighted text and select Insert Text Output. The Text Output Value Properties dialog box opens. 



5. Set the output value settings.
The Data Table column name box displays Select_a_FlightOutput_Text_out. Change this to depart_flight_price. 

Click OK to accept the other default settings. QuickTest adds the depart_flight_price column to the Data Table. 

Note that QuickTest displays the captured text—270—in the first row of the depart_flight_price column in the Data Table. During the first iteration of the test run, QuickTest replaces this with the actual text retrieved from the application—in this case, also 270. (In subsequent iterations, QuickTest adds the actual retrieved text to the appropriate row of the column.) 

QuickTest adds the output value step to your test above the selected step [image: image22], displayed in the test tree, under the "Select a Flight" page. 

6. Modify the table checkpoint that checks the ticket price displayed in the flight Summary table.
In the test tree, expand (+) "Welcome:Mercury" > "Book a Flight:". 

Right-click Checkpoint "New York to", and select Checkpoint Properties. The Table Checkpoint Properties dialog box opens.
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7Click column 3 in row 3 (the checked cell). In the Check value as area, click Parameter and select depart_flight_price from the Parameter name box. 

Click OK. In the test tree, the [image: image23]icon is displayed beside the checkpoint, indicating that it is parameterized. 

7. Save the test.
Select File > Save or click the Save button [image: image24]. 
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